Change log for JSR 291

Please see the latest OSGi Service Platform Release 4 Errata. The errata for Core Specification Version 4.1 applies to JSR 291.